Jump to content
Old Guys Gaming
Search In
  • More options...
Find results that contain...
Find results in...

Steam ARMA 3 Launcher.....


Recommended Posts

I have had the same issue as well for about a month. Put in a help desk request and worked with Dane on this issue and he's not sure why this is happening. I did find a workaround that worked for me until last week which was to put this link in my internet browser "http://server.old-guys-gaming.com:2309" (without quotes) and it would take me to a white background page that had the text
"Username or Password Not Given." and when I went back to the ARMA 3 launcher the server was now showing up. He also said others found it by using a VPN and using a U.S> server and that also worked. My "Surfshark" VPN did not help but maybe some of you can try if you have a VPN as well?

  • Upvote 1
Link to comment
Share on other sites

Glad it worked for you but it stopped working for me. I am forced to switch to another server as using a VPN, the link, nothing will show the server name and I can't direct connect because Battleeye fails and kicks me out. Good luck and enjoy it while it works.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Terms of Use & Privacy Policy


This website is not affiliated or authorized by Bohemia Interactive a.s. Bohemia Interactive, ARMA, DAYZ and all associated logos and designs are trademarks or registered trademarks of Bohemia Interactive a.s.